build: upgrade to Flutter 3.47.4 (AGP 9.1 / Gradle 9.3, iOS 15 + UIScene), refresh deps and CI
Build Android APK / Build Release APKs (push) Failing after 1m7s
Build Android APK / Build Release APKs (push) Failing after 1m7s
Flutter 3.24.5 -> 3.47.4 with the matching toolchain changes: - pubspec: Dart ^3.11, Firebase core 4 / auth 6 / firestore 6 / storage 13, drop unused image_cropper, logging, change_app_package_name, pdf_widget_wrapper; pin path_provider_android <2.3 (needs NDK/CMake, not feasible on the ARM64 Gitea runner) - Dart: CardTheme -> CardThemeData, replace deprecated withOpacity, Matrix4.scale, DropdownButtonFormField.value - iOS: deployment target 15.0, UIScene lifecycle (AppDelegate/Info.plist), untrack stale Podfile.lock, add LaunchImage asset set - Android: Gradle 9.3.1, AGP 9.1.0, Kotlin 2.4.0, google-services 4.5.0, layout.buildDirectory instead of removed Project.buildDir, remove manifest package attribute and duplicate MainActivity, kotlin.incremental=false - CI: pin FLUTTER_VERSION in both workflows; iOS on macos-26 with SwiftPM disabled (CocoaPods only); Gitea job keeps cirruslabs 3.44.0 as base image (images discontinued) and switches the bundled Flutter SDK by git tag Co-Authored-By: Claude Opus 5 <noreply@anthropic.com>
This commit is contained in:
@@ -20,11 +20,14 @@ pluginManagement {
|
||||
}
|
||||
}
|
||||
|
||||
// Versions follow the Flutter 3.47 project template (see
|
||||
// packages/flutter_tools/lib/src/android/gradle_utils.dart in the Flutter SDK).
|
||||
// Flutter refuses to build with AGP < 8.11.1, Kotlin < 2.2.20 or Gradle < 8.14.
|
||||
plugins {
|
||||
id "dev.flutter.flutter-plugin-loader" version "1.0.0"
|
||||
id "com.android.application" version "8.5.2" apply false
|
||||
id "org.jetbrains.kotlin.android" version "1.9.22" apply false
|
||||
id "com.google.gms.google-services" version "4.4.1" apply false
|
||||
id "com.android.application" version "9.1.0" apply false
|
||||
id "org.jetbrains.kotlin.android" version "2.4.0" apply false
|
||||
id "com.google.gms.google-services" version "4.5.0" apply false
|
||||
}
|
||||
|
||||
include ":app"
|
||||
|
||||
Reference in New Issue
Block a user